Drupal 6 support has been officially removed

Közzétéve
2020-05-06 07:35
Written by

As of CiviCRM 5.25, the minimum required PHP version is version 7.1, with PHP 7.3 being the recommended version. Since Drupal 6 does not support PHP 7.1 (except LTS vendors, such as myDropWizard), and since there are very few active CiviCRM sites on Drupal 6, we have decided to officially stop supporting Drupal 6.

We strongly encourage Drupal 6 users to upgrade to a supported content management system (CMS), such as Drupal 7, Drupal 8, Backdrop or WordPress. Depending on how much of the content management integration is used, it can be as simple as installing a new CMS, then re-importing the CiviCRM database in that site. For more information, see the switching CMS platform documentation.

If you need a hand, you can find a CiviCRM expert on our partner and contributor listing.

Are you still on Drupal 6? Have you upgraded recently? We would love to hear from you. Please leave a comment!

Filed under

Comments

Some interesting old blog posts from 2011, nine years ago!

- https://civicrm.org/blog/eileen/a-future-for-drupal-6-civicrm
- https://civicrm.org/blog/sschmoller/civicrm-needs-work-securely-drupal-…

A lot of work went into supporting Drupal6 for a long time, which I think is important as our users often do not have a big maintenance budget. A big thanks to everyone who contributed.

Looking forward, it will be interesting to see how much longer we can support Drupal 7, which can also be a challenge to support with recent PHP versions.