Published
Monday, July 6, 2009 - 11:15
Written by

The team has released version 2.2.7 today. This release includes an important security update - and we recommend that you upgrade sites to this release as soon as possible. 2.2.7 also includes phase 1 of CiviReport - with 14 built-in report templates with coverage of contact data, contributions, events and memberships. Stay tuned for a separate blog post with lots more details on the new reporting features. You can review a complete list of 2.2.7 changes on the issue tracker.  

Download

You can download CiviCRM 2.2.7 at our download page. Select from the Newest Files section at the top of the page. The filenames include the 2.2.7 label: civicrm-2.2.7…. Be sure and download the correct version for your CMS (Drupal / Joomla! / Standalone).  

New 2.2.7 Installations

If you are installing CiviCRM 2.2.7 from scratch, use the installation instructions linked below:

 

Upgrading to 2.2.7

The procedure for upgrading to 2.2.7 is the same for upgrading 2.1.x and prior 2.2.x versions. We have provided a browser-based upgrade script. Instructions for upgrading are here:

 

Reporting Issues and Bugs

We look forward to getting your feedback on the release in the coming days. If you have questions about installing, upgrading and / or using 2.2.x features - or you're seeing a problem and you're not sure if it's a bug - please post your issue to the applicable section of the Community Forum. Include as many specifics as possible about the issue or question. Bugs should be reported via our issue tracking system. Please select 2.2.7 in the ‘Affects Version’ dropdown. You will need to register as a user – this ensures that we can follow-up with you on your bug reports if necessary. Please ensure that the bug you’ve found is not reported already by checking the open issues queue.

Comments

Hi

I get this error when I click on the file:
The "civicrm-2.2.7-drupal.tar" file could not be found. Please select another file

:-) Bo

Please use the community forum to get help :-)