Published
Friday, March 23, 2018 - 16:23
Written by

Ginkgo Street Labs is pleased to announce the availability of CiviVolunteer 2.3.0 and Angular Profiles 1.1.0 for CiviCRM 4.7.31 and above.

Site administrators maintaining an older version of CiviCRM should upgrade core before upgrading these extensions. CiviCRM 4.7.31 introduced an improvement to how CiviCRM manages the BackboneJS library which these extensions need to account for in order to continue functioning properly. The extension updates are not backward-compatible and should not be applied to pre-4.7.31 sites.

Additionally, CiviVolunteer 2.3.0 contains a number of modest improvements and minor bugfixes (and a few more for which code was contributed but no issue created).

Installation

CiviVolunteer can be downloaded from the CiviCRM extensions directory or installed from within CiviCRM from the Administer menu, under System Settings > Manage Extensions (some systems may have it under Custom Data and Screens > Manage Extensions). You'll also need to install version 1.1.0 or later of Angular Profiles – a utility extension which helps the AngularJS and BackboneJS JavaScript frameworks play nicely together – in order for CiviVolunteer to function properly.

UPGRADING

If you're currently using CiviVolunteer, the new version should be available as an update on the Manage Extensions page soon. Some users have reported that their CiviVolunteer settings "disappear" after an upgrade. This is due to an issue with CiviCRM's extension system, but can usually be resolved by flushing CiviCRM's caches. For more information, see CRM-21210.

Filed under

Comments

Hi Frank,

Is there still a sandbox with the latest version of CiviVolunteer available? Would love to try this out. Great work!