Published
Wednesday, April 14, 2010 - 00:07
Written by
We are excited to announce that CiviCRM 3.1.4 has been released, and is now available for download. You can also try it out on our demo site. This release includes ~100 bug fixes/improvements to existing functionality. We recommend that sites currently running v3.1.3 or earlier upgrade to this version as soon as possible.

Notice for Sites Using Moneris Payment Processor

We were unable to obtain an appropriate GPL license for the Moneris plugin code, and therefore that file has been removed from our downloads. If your site uses Moneris for payment processing, you will need follow these directions to download the required code after upgrading your site to 3.1.4.  

Download

You can download CiviCRM 3.1.4 at our download page. Select from the Newest Files section at the top of the page. The filenames include the 3.1.4 label: civicrm-3.1.4…. Be sure and download the correct version for your CMS (Drupal / Joomla! / Standalone).  

New 3.1.4 Installations

If you are installing CiviCRM 3.1.4 from scratch, use the installation instructions linked below:  

Upgrading to 3.1.4

The procedure for upgrading to 3.1.4 is the same for upgrading from 2.2.x and from prior 3.1 versions (3.1.x or one of the 3.1 beta releases). We have provided a browser-based upgrade script. Instructions for upgrading are here:  

Reporting Issues and Bugs

We look forward to getting your feedback on the release in the coming days. If you have questions about installing, upgrading and / or using 3.1.x features - or you're seeing a problem and you're not sure if it's a bug - please post your issue to the applicable section of the Community Forum. Include as many specifics as possible about the issue or question. Bugs should be reported via our issue tracking system. Please select 3.1.4 in the ‘Affects Version’ dropdown. You will need to register as a user – this ensures that we can follow-up with you on your bug reports if necessary. Please ensure that the bug you’ve found is not reported already by checking the open issues queue.
Filed under

Comments

Although 3.1.4 is the latest version, once you get to the download page at Sourceforge the green box at the top still says 3.1.3. Click stable releases to get to the 3.1.4 version. Might want to correct this, team.

http://sourceforge.net/projects/civicrm/files/