Sunday, March 6, 2016 - 14:01
Written by

Mark your calendars, the api team will be doing a webinar introducing api version 4 on Thurs March 24 12:15pm EST.

For anyone that's developed an extension or other integration with CiviCRM, you know how important a good api is. CiviCRM's api version 3 is incredibly useful - it's mature, stable, tested, robust, and even has a handy gui explorer that writes code for you!

Great as it is, api v3 is now 5 years old, and while it may well last another 5 years before being retired, it's time to think about the future. Over the last 5 years it's managed to build up a fair amount of cruft and oddities, which we keep around for the sake of backward-compatability. Bumping up to version 4 represents a chance to start with a clean slate, lose the cruft, and embrace new technologies and techniques.

As of this writing, api v4 is in its infancy. It supports a single entity (Participant, which I picked for no other reason than it's one of the cruftiest and worst-supported by api v3), and a handful of actions. Our idea is that by getting a single entity nailed down we will work out most of the details of the api4 framework and test contract, and then adding support for more entities should go quickly.

Want to learn more? Check out the work-in-progress Api4 Extension, and join us for the webinar on Thurs March 24 12:15pm EST.

Join the webinar now.

Filed under


Are there any details about the webinar yet? =]

Just posted the link. See above.