Published
Tuesday, February 21, 2012 - 10:13
Written by

If you've recently upgraded to CiviCRM 4.1, you'll need to upgrade your webform_civicrm as well. Versions 2.3 and below are not fully compatible with Civi 4.1. Version 2.4 is, and will be released in the next couple of days, especially if I get a few comments on this post from people who have sucessfully tested it! The latest -dev is stable and working, so please feel free to download it and try it out on your 4.1 site!

Note: webform_civicrm 2.4 is not backwards-compatible with older versions of CiviCRM, and should only be used with 4.1.x

New Features In webform_civicrm 2.4

  • Adds contact image and language pref fields
  • More options for matching/updating existing activities
  • Support for new multi-valued contact sub-type
  • Improved group and tag fields
  • Can include the entire webform submission in the activity details, as well as an edit link
  • Can generate a contact checksum for use in webform-generated emails
  • Supports cid1=0 in URL, so the "not you" link no longer logs you out
  • Support custom data for cases

This version also has some behind-the-scenes enhancements to improve efficiency, compatibility, and pave the way for future improvements. As always, Drupal 6 and 7 are both supported :)

Filed under

Comments

Congratulations on getting a 4.1 compatible version of this excellent module out the door so soon after 4.1 became stable. And thanks for continuing to make useful enhancements!

Thanks Colemanw for continuing to extend and upgrade this module. I am now using the dev version on my site and it seems to be working fine.

The ability to have multiple tags on a form and also to put the whole submission in the activity details are really very helpful.

This is a great module and it is nice to have it working before we have even gotten around to the 4.1 upgrade.

Glad that this module is helping so many people. 700 users and counting!