Published
Monday, December 17, 2018 - 21:51
Written by

This is just a quick reminder that as announced in August the CiviCRM release on 2 Jan 2019 will be the last release supporting PHP 5.5. 

Upstream php.net support for PHP versions 5.6 and 7.0 also ends at the end of this month; if you are on these versions, we recommend that you consider your upgrading. Our goal is that CiviCRM will support PHP 5.6 and 7.0 through to September and December 2019 respectively. We will re-evaluate that goal in March per the previous announcement.

Our recommended version is PHP 7.2.  We have only done very limited testing on the newly released PHP 7.3 so we are not in a position to recommend 7.3 yet. Note that if you have a saved SMTP password you will need to re-save it after upgrading to PHP 7.2.

At this stage there is no intention to continue supporting PHP 5.5 in future ESR releases. However, combining longer term legacy version PHP support with the subscriber ESR service is something that could be considered if there is demand to continue to have support for older versions beyond when we drop them from the main release.

Filed under