Published
Thursday, September 21, 2017 - 09:27
Written by

Ginkgo Street Labs is pleased to announce the availability of CiviVolunteer 2.2.2 for CiviCRM 4.7.21 and above. Site administrators maintaining an older version of CiviCRM should upgrade core before upgrading CiviVolunteer.

This release includes five bugfixes. The most substantial of these is VOL-310, which arose from changes introduced to CiviCRM core's Angular integration in version 4.7.21 and which resulted in a more or less complete breakage of the extension. Thanks to Bob Silvern for bug reports and patch testing; Travis Megee and Eric Goldhagen for patch testing; Agileware for patch testing, contributed code, and funding; Eileen McNaughton, Fuzion, and Tadpole Collective for funding; and Tim Otten for providing various technical signposts.

This is important enough that it bears repeating: users of CiviCRM 4.7.21 and above should use CiviVolunteer 4.7.21-2.2.2 or greater; users of any lesser version of CiviCRM should not upgrade past 4.6-2.2.1. The changes required to resolve VOL-310 could not feasibly be made in a backward-compatible fashion; installing the latest version of CiviVolunteer on an older system will completely break the extension. (Presently, CiviCRM doesn't have a way to support minor release compatibility checks -- though the extensions working group is working on it -- so for now this announcement is the best we can do.)

Installation

CiviVolunteer can be downloaded from the CiviCRM extensions directory or installed from within CiviCRM from the Administer menu, under System Settings > Manage Extensions (some systems may have it under Custom Data and Screens > Manage Extensions). You'll also need to install version 1.0.1 or later of Angular Profiles – a utility extension which helps the Angular and Backbone JavaScript frameworks play nicely together – in order for CiviVolunteer to function properly.

UPGRADING

If you're currently using CiviVolunteer, the new version should be available as an update on the Manage Extensions page soon. Some users have reported that their CiviVolunteer settings "disappear" after an upgrade. This is due to an issue with CiviCRM's extension system, but can usually be resolved by flushing CiviCRM's caches. For more information, see CRM-21210.

Filed under