Published
Tuesday, May 7, 2019 - 01:47
Written by
If your organisation uses CiviCRM with Drupal, and would like to do in the future, we need your help!
 
Over the past few years lots of amazing work has been done on the unofficial Drupal 8 CiviCRM release.
The CiviCRM core team have looked at this and are now in a position to complete the work to make this an official CiviCRM release. This means they will make changes so
  • CiviCRM can easily be installed with Drupal 8
  • They will ensure CiviCRM works with Views in Drupal 8
  • Going forward future CiviCRM releases will be tested with Drupal 8
This Make It Happen is raising $25,000 which will be used to complete this work.
Any money raised by the Make It Happen which is not spent on the initial work will be used to support future work on the CiviCRM Drupal 8 integration as needed. 
 
What about Drupal 9? Isn't that being released soon?
Both Drupal 7 and 8 are officially supported until November 2021. But the move from Drupal 8 to Drupal 9 will not be the same as previous Drupal major updates. It will be much easier to migrate existing sites between Drupal 8 to 9. For more information see https://dri.es/drupal-7-8-and-9.
The CiviCRM core team has looked at this and the code changes required to ensure CiviCRM works with Drupal 9 should be minimal.
So very importantly this Make It Happen work is also preparation for Drupal 9.
 
If your organisation uses CiviCRM with Drupal then please contribute to this Make It Happen.